<html><body><div style="color:#000; background-color:#fff; font-family:times new roman, new york, times, serif;font-size:12pt"><div><span>my shimrc file isn't identical:</span></div><div style="color: rgb(0, 0, 0); font-size: 16px; font-family: 'times new roman', 'new york', times, serif; background-color: transparent; font-style: normal; "><span style="background-color: transparent; "><br></span></div><div style="color: rgb(0, 0, 0); font-size: 16px; font-family: 'times new roman', 'new york', times, serif; background-color: transparent; font-style: normal; "><span style="background-color: transparent; ">let DbmsHost = localhost,</span><br></div><div style="color: rgb(0, 0, 0); font-size: 16px; font-family: 'times new roman', 'new york', times, serif; background-color: transparent; font-style: normal; "><span><span class="Apple-tab-span" style="white-space:pre">        </span>ApiLevel = 23;</span></div><div style="color: rgb(0, 0, 0); font-size: 16px;
 font-family: 'times new roman', 'new york', times, serif; background-color: transparent; font-style: normal; "><span><br></span></div><div style="color: rgb(0, 0, 0); font-size: 16px; font-family: 'times new roman', 'new york', times, serif; background-color: transparent; font-style: normal; ">feedhost commented out a little lower:</div><div style="color: rgb(0, 0, 0); font-size: 16px; font-family: 'times new roman', 'new york', times, serif; background-color: transparent; font-style: normal; "><span style="background-color: transparent; "><br></span></div><div style="color: rgb(0, 0, 0); font-size: 16px; font-family: 'times new roman', 'new york', times, serif; background-color: transparent; font-style: normal; "><span style="background-color: transparent; ">#FeedHost = localhost,</span><br></div><div style="color: rgb(0, 0, 0); font-size: 16px; font-family: 'times new roman', 'new york', times, serif; background-color: transparent; font-style: normal;
 "><br></div><div>comments suggest this is already default, so not sure if i need to add it as you have. &nbsp;i've looked at ib's documentation</div><div>and my gateway configuration, can't find what "version" of the API it's using, but i'm guessing this is where it's&nbsp;<span style="font-size: 12pt; ">breaking.</span></div><div style="color: rgb(0, 0, 0); font-size: 12pt; font-family: 'times new roman', 'new york', times, serif; background-color: transparent; font-style: normal; "><span style="font-size: 12pt; ">i'm wondering if the shim's api levels ib specified ... ?</span></div><div><br></div><div style="color: rgb(0, 0, 0); font-size: 16px; font-family: 'times new roman', 'new york', times, serif; background-color: transparent; font-style: normal; ">i have tried firing the shim with your specified settings and got the same complaint.</div><div style="color: rgb(0, 0, 0); font-size: 16px; font-family: 'times new roman', 'new york', times, serif;
 background-color: transparent; font-style: normal; "><br></div><div style="color: rgb(0, 0, 0); font-size: 16px; font-family: 'times new roman', 'new york', times, serif; background-color: transparent; font-style: normal; ">paul, i appreciate all your help.</div><div style="color: rgb(0, 0, 0); font-size: 16px; font-family: 'times new roman', 'new york', times, serif; background-color: transparent; font-style: normal; "><br></div>  <div style="font-family: 'times new roman', 'new york', times, serif; font-size: 12pt; "> <div style="font-family: 'times new roman', 'new york', times, serif; font-size: 12pt; "> <div dir="ltr"> <font size="2" face="Arial"> <hr size="1">  <b><span style="font-weight:bold;">From:</span></b> Paul &lt;paul.analytic@gmail.com&gt;<br> <b><span style="font-weight: bold;">To:</span></b> Harry Balzer &lt;harry.balzer@yahoo.com&gt;; trading shim general list &lt;ts-general@mail.trading-shim.org&gt; <br> <b><span style="font-weight:
 bold;">Sent:</span></b> Saturday, August 25, 2012 1:19 AM<br> <b><span style="font-weight: bold;">Subject:</span></b> Re: [ts-general] CentOS 6, Additional database build issue<br> </font> </div> <br>Hi Harry,<br>I've used the shim with the gateway before.&nbsp; Just tested it again, and<br>it seems to work - albeit I am using an old version of the IB gateway from<br>august 2011 (I haven't upgraded TWS for ages either).<br><br>I'm also setting the shim to use Api Level of 47 in ~/.shimrc:<br><br>let DbmsHost = localhost,&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;  <br>&nbsp; &nbsp; FeedHost = localhost,&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;  <br>&nbsp; &nbsp; ApiLevel = 47; <br><br>I forget why I use 47, but seem to remember having problems with other values.<br><br>regards,<br><br>Paul<br><br><br> </div> </div>  </div></body></html>